
  

THE BEASTTHE BEAST
MANUAL GUIDEMANUAL GUIDE

VARIANTS:
THE BEAST STANDARD
  > Line follower
  > Maze Solver
  > Sumo fight
THE BEAST
  > with PS2 Controlled
  > with Pan Tilt
THE BEAST
  > with Bluetooth Controlled
THE BEAST*
 > with E-ARM (Robotic Arm)
 > with PS2 Controlled
THE BEAST*
  > with 3 Distance Sensors
THE BEAST *
  > with 3 IR Proximity Sensors
*Under development

Included:
- USB Cable Type A to mini B
- Samung Battery Charger



  

THE BEASTTHE BEAST
STANDARDSTANDARDDESCRIPTIONS

VARIANTS:
 THE BEAST
 

 

> Line follower

 
> Maze Solver

 > Sumo fight

>Optional
- Add wireless
   devices

- has gizDuino PLUS Atmega644P
     microcontroller for basic entry level robot functions and open
   circuit board. The Open circuit enables the user to boarden the 
   capabilities of prototyping by adding certain peripheral to the
   board.
- to follow the black line on the track from start to finish line. It has 
    digital line calibration to make it easy.

- to solve the maze courses, you can upload the sketch given or modify
    it to remote control via wireless devices (Optional).

- to fight with other opponents robots with in the ring, it has line/
    outside avoidance.

- you can add bluetooth, PS2 controller with UHF STD, Wifi.. etc
   to control it wirelessly.



  

THE BEASTTHE BEAST
SPECIFICATIONS

General Specifications:
  Battery: 2x7.4V Li-ion 1600 rechargeable
 On-board Peripherals: 
  - IC ATmega644P w/ 64KB Flash memory
  - 2x, Beefy Motor Driver
  - 4x,WRF-370CH DCGeared Motors 131RPM
  - 3-Ch IR line sensor CNY70,10mm range
  - Mobot Shield
  - Serial LCD II 4x20 Display
  - 1x Distance Sensor
  - 1x SG-90 Servo Motor

Features:
- The most Poweful mobile robot as now.
    Can join in war robotics competitions.
- With 4x20 LCD Display for monitoring the 
    Status of sensors.
- Single Distance sensor for detecting objects
   Or wall avoidance.
- Can detect black line to follows.
- 100% Arduino Board Compatible!
- Program it using Arduino IDE 100% code
   compatible
- Samsung Rechargeable with LED indicators
    If the batteries are full.
- Using Mobot Shield for Easy connections.
- Customized 2 rubber belts for each sides,
   3 wheels on left and right.



  

GizduinoPlusGizduinoPlus
ATmega644PATmega644PMAJOR PARTS



  

GizduinoPlusGizduinoPlus
ATmega644PATmega644PPin Descriptions

Table 1.Power Connections
Pin Functions Descriptions
RST Reset the module 
+3v3 +3.3v Power Supply
+5V +5V Power Supply
GND Ground
GND Ground
VIN Input Voltage = External Input Supply

Table 2.LED  Indicators
LED Functions Descriptions
D2 +5V Indicator 
D3 +3.3v Indicator
D4 Digital Pin 13 Indicator
D5 Rx pin indicator
D6 Tx pin indicator

Table 3.Digital I/Os & Analog Inputs
Pin Functions Descriptions
0 Digital pin 0/Rx 
1 Digital pin 1/Tx
2 Digital pin 2 
3 Digital pin 3
4 Digital pin 4/PWM
5 Digital pin 5/PWM 
6 Digital pin 6/PWM 
7 Digital pin 7/PWM
8 Digital pin 8 
9 Digital pin 9/PWM 
10 Digital pin 10/PWM/SS
11 Digital pin 11/MOSI 
12 Digital pin 12/MISO
13 Digital pin 13/SCK 
14 Digital pin 14/A0
15 Digital pin 15/A1  
16 Digital pin 16/A2 
17 Digital pin 17/A3
18 Digital pin 18/A4 
19 Digital pin 19/A5 



  

Mobot ShieldMobot Shield
MAJOR PARTS



  

Mobot ShieldMobot Shield
MAJOR PARTS
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Jumper pad

Jumper pad



  

Mobot ShieldMobot Shield
Pin Descriptions: Power

Table 1.Power Connections
Pin Functions Descriptions Connected to gizDuino PLUS
+5V +5V Power Supply +5V 
GND Ground GND
GND Ground GND
+VIN +VIN Power Supply +VIN
BATT Battery Connections -
VM Voltage Input Jumper/Shorted



  

Mobot ShieldMobot Shield
Wiring: Beefy Motor Driver

Table 2.Beefy Motor Driver Connections
 “A” Beefy Motor Driver Descriptions Connected to gizDuino PLUS
GND Ground GND
RST Reset +5V
PH/SR +5V +5V
PL/PH Directions Digital Pin 8
PWH/PWL +5V +5V
PWL/PWH ON/PWM Digital Pin 9

“B” Beefy Motor Driver Descriptions
GND Ground GND
RST Reset +5V
PH/SR +5V +5V
PL/PH Directions Digital Pin 11
PWH/PWL +5V +5V
PWL/PWH ON/PWM Digital Pin 10



  

Mobot ShieldMobot Shield
Wiring: Hybrid Motor Driver

Table 3.Hybrid Motor Driver Connections
“A” Hybrid Motor Driver Descriptions Connected to gizDuino Plus
DIR- Low Direction GND
DIR+ High Direction Digital Pin 8
EN- Low Enable GND
EN+ Directions Digital Pin 9
“B” Hybrid Motor Driver Descriptions
DIR- Low Direction GND
DIR+ High Direction Digital Pin 11
EN- Low Enable GND
EN+ Directions Digital Pin 10



  

Mobot ShieldMobot Shield
Wiring: 3Ch Line Sensors & Serial LCD II

Table 4. 3CHLine Sensor Connections
Pin Functions Descriptions Connected to gizDuino Plus
D1 Line sensor 1 Digital Pin 7
D2 NC -
D3 Line sensor 2 Digital Pin 6
D4 NC -
D5 Line sensor 3 Digital Pin 5
VCC +5V Supply +5V
GND Ground GND

Table 5. Serial LCD II
Pin Functions Descriptions Connected to gizDuino
TX Trasmit Digital Pin 2/Serial1 RX
RX Received Digital Pin 3/Serial1 TX
GND Ground GND
VCC +5V Supply (NA) -



  

Mobot ShieldMobot Shield
Pin Descriptions: UHF, Bluetooth & Servo
Table 6. UHF STD RX ONLY
Pin Functions Descriptions Connected to gizDuino Plus
RX Received Digital Pin 1/Serial0  TX
TX Trasmit Digital Pin 0/Serial0 RX
GND Ground
VCC +5V Supply

Table 7. Bluetooth Module HC-05
Pin Functions Descriptions Connected to gizDuino Plus
RX Received Digital Pin 1/Serial0  TX
TX Trasmit Digital Pin 0/Serial0 RX
GND Ground GND
VCC 5V Supply +5V

Table 8. Servo Motors (Caution* VCC & GND Interchanged)
“Servo 1 “Pin Functions Descriptions Connected to gizDuino Plus
OUT Signal Digital Pin 12
GND Ground GND
VCC +5V Supply +5V
“Servo 2“Pin Functions Descriptions
OUT Signal Digital Pin 4
GND Ground GND
VCC +5V Supply +5V



  

Mobot ShieldMobot Shield
Wiring: UHF, Bluetooth, Servo
& MQ-X Gas sensor

Table 9. MQ-X Gas Sensor Connections
Pin Functions Descriptions Connected to gizDuino
VCC +5V Supply +5V
GND Ground GND
OUT Analog Output Analog Pin 5



  

Mobot ShieldMobot Shield
Pin Descriptions: Distance Sensors

Table 10. HC-SR04 Distance Sensor
“1“Pin Functions Descriptions Connected to gizDuino Plus
VCC +5V Supply +5V
TRIG Trigger Digital Pin 30
ECHO Echo Digital Pin 31
GND Ground GND
“2“Pin Functions Descriptions
VCC +5V Supply +5V
TRIG Trigger Digital Pin 28
ECHO Echo Digital Pin 29
GND Ground GND
“3“Pin Functions Descriptions
VCC +5V Supply +5V
TRIG Trigger Digital Pin 26
ECHO Echo Digital Pin 27
GND Ground GND



  

Mobot ShieldMobot Shield
Wiring: Distance Sensors



  

Mobot ShieldMobot Shield
Pin Descriptions: Compact Proximity Sensors

Table 11. Compact Proximity Sensors
“1“Pin Functions Descriptions Connected to gizDuino Plus
VCC +5V Supply +5V
GND Ground GND
OUT Digital Output Digital Pin 28
“2“Pin Functions Descriptions
VCC +5V Supply +5V
GND Ground GND
OUT Digital Output Digital Pin 27
“3“Pin Functions Descriptions Connected to gizDuino Plus
VCC +5V Supply +5V
GND Ground GND
OUT Digital Output Digital Pin 26



  

Mobot ShieldMobot Shield
Wiring: Compact Proximity Sensors



  

Mobot ShieldMobot Shield
Pin Descriptions: Analog Inputs,16-Channel,Color Sensor

Table 12. Analog Inputs
Pin Functions Descriptions Connected to gizDuino Plus
VCC +5V Supply +5V
GND Ground GND
INPUT Analog Input A0 to A4

Table 13. 16-Channel Servo Controller
Pin Functions Descriptions Connected to gizDuino Plus
3.3V 3.3V Supply -
GND Ground GND
RX Receiver Digital Pin 25
TX Transmit Digital Pin 24

Table 14. Color Sensor
Pin Functions Descriptions Connected to gizDuino Plus
GND Ground GND
OUT Output Digital Pin 31
S2 S2 Digital Pin 30
S3 S3 Digital Pin 29
VCC +5V Supply +5V



  

Mobot ShieldMobot Shield
Pin Descriptions: Tact Switch buttons,Buzzer

Table 15. 4 Buttons
Pin Functions Descriptions Connected to gizDuino Plus
S2 Tact Switch 2 Reset Button
S3 Tact Switch 3  Digital Pin 14
S4 Tact Switch 4  Digital Pin 15 
S5 Tact Switch 5  Digital Pin 16
S6 Tact Switch 6  Digital Pin 17

Table 16. Buzzer
Pin Functions Descriptions Connected to gizDuino Plus
Buzzer Sound Alarm Digital Pin 13

Table 17. Relays
Pin Functions Descriptions Connected to gizDuino Plus
K7 Relay Digital Pin 20
K8 Relay Digtial Pin 21



  

Mobot ShieldMobot Shield
LED Indicators,Buttons, Buzzer & Relays:



  

Softwares and library

Arduino IDE

Drivers Install this first!

Library Add to My Documents>Arduino>libraries

www.e-gizmo.net/oc/kits documents/ARDUINO IDE SOFTWARES
  Download Arduino 1.8.8 egizmo (Windows)
  Choose your Arduino IDE for your OS.

www.e-gizmo.net/oc/kits documents/ARDUINO IDE SOFTWARES
  Download Prolific Driver v10.0 (Windows)
 (For Mac OS users) Download md_PL2303_MacOSX or latest

  Download  and Unzip this before you move to libraries)

Libraries:
Servo
NewPing
Software Serial

http://www.e-gizmo.net/oc/kits
http://www.e-gizmo.net/oc/kits


  

Add Sample codes to Sketchbook
Downloads the Sample Codes from:
https://www.e-gizmo.net/oc/kits%20documents/THE%20BEAST%20ROBOT/THE_BEAST_CODES.zip

1. Then place it to My Documents>Arduino folder> (Place here and Unzip/Extract All)
2. Open the Arduino IDE. Go to> File> Sketchbook> THE_BEAST_CODES
Note: Make Sure you already have the included libraries. Page 21

https://www.e-gizmo.net/oc/kits%20documents/THE%20BEAST%20ROBOT/THE_BEAST_CODES.zip


  

The Arduino IDE



  

Connect the BEAST to PC

USB Connector

USB Cable

Open Arduino IDE.



  

Uploading codesMotor Test
On the Arduino IDE.
1. Motor Test codes
    Go to File>Sketchbook>THE_BEAST..> MOTORTEST

2. Board select
     Go to Tools>Boards>gizDuino + w/ Atmega644

3. Port select
     Go to Tools>Port>COM#
Select the correct port
Go to Device Manager
      if you're not sure.

Tips for uploading:
 Disable the Rx pin by switching
the Toggle Switch.

Enable RX

Disable RX

4. After you switched it. Click Upload.



  

MOTOR TEST
 1. After uploading your code for Motor Test.
     Enable the RX pin to show display on the LCD.

2. You can see the direction of motors will turn Forward,
    STOP, BACKWARD,STOP,TURN LEFT, STOP, 
     TURN RIGHT & STOP.

Enable RX

Disable RX
E-Gizmo
Motor Test

Move
Forward

Backward



  

Pin assignments in Motor test
//Right
#define PH_MOTOR_2_DIRECTION                      8
#define PWH_ON_SPEED_CONTROL_2            9
//Left
#define PWH_ON_SPEED_CONTROL_1            10
#define PH_MOTOR_1_DIRECTION              11



  

Uploading codesLine Follower
On the Arduino IDE.
1. Line Follower codes
    Go to File>Sketchbook>THE_BEAST..> LINEFOLLOWER

2. Board select
     Go to Tools>Boards>gizDuino + w/ Atmega644

3. Port select
     Go to Tools>Port>COM#
 Select the correct port
 Go to Device Manager
      if you're not sure.

Tips for uploading:
  Disable the Rx pin by switching
the Toggle Switch.

Enable RX

Disable RX

4. After you switched it. Click Upload.



  

LINE SENSOR
 1. After uploading your code for linesensors.
     Enable the RX pin to show display on the LCD.

2. Place the BEAST to the "black
     line” to follow it.

Enable RX

Disable RX
E-Gizmo
LineFollower



  

Pin assignments in Line Sensor

#define LEFT_LINE_SENSOR           7       // Line sensor left 
#define CENTER_LINE_SENSOR        6       // Line sensor center
#define RIGHT_LINE_SENSOR         5       // Line sensor right

LS1
LS2

LS3

Reading Line Sensors Ouput:
Black = 1
White =0



  

MAZE/SUMO
DISTANCE SENSOR CONNECTIONS

SG-90 Servo : For Turning the Sensors
In 160 degrees directions.

Distance Sensor: Searching for Wall or Objects.



  

Uploading codesSumo
On the Arduino IDE.
1. Sumo codes
    Go to File>Sketchbook>THE_BEAST..> SUMO

2. Board select
     Go to Tools>Boards>gizDuino + w/ Atmega644

3. Port select
     Go to Tools>Port>COM#
Select the correct port
Go to Device Manager
      if you're not sure.

Tips for uploading:
 Disable the Rx pin by switching
the Toggle Switch.

Enable RX

Disable RX

4. After you switched it. Click Upload.



  

SUMO FIGHTING
 1. After uploading your code for linesensors.
     Enable the RX pin to show display on the LCD.

2. Place the BEAST to the Sumo Arena.

Enable RX

Disable RX
E-Gizmo
SUMO

!



  

Uploading codesObstacle
On the Arduino IDE.
1. Maze codes
    Go to File>Sketchbook>THE_BEAST..> OBSTACLE

2. Board select
     Go to Tools>Boards>gizDuino + w/ Atmega644

3. Port select
     Go to Tools>Port>COM#
Select the correct port
Go to Device Manager
      if you're not sure.

Tips for uploading:
 Disable the Rx pin by switching
the Toggle Switch.

Enable RX

Disable RX

4. After you switched it. Click Upload.



  

OBSTACLE/MAZE SOLVER
 1. After uploading your code for linesensors.
     Enable the RX pin to show display on the LCD.

2. Place the BEAST to the Maze obstacle.

Enable RX

Disable RX
E-Gizmo
MAZE

START

FINISH



  

Uploading codesPS2 Controlled
On the Arduino IDE.
1. PS2 Controlled
    Go to File>Sketchbook>THE_BEAST..> PS2 CONTROLLED

2. Board select
     Go to Tools>Boards>gizDuino + w/ Atmega644

3. Port select
     Go to Tools>Port>COM#
Select the correct port
Go to Device Manager
      if you're not sure.

Tips for uploading:
 Disable the Rx pin by switching
the Toggle Switch.

Enable RX

Disable RX

4. After you switched it. Click Upload.



  

PS2 CONTROLLED
 1. After uploading your code for linesensors.
     Enable the RX pin to show display on the LCD.

2. Use the PS2 Controlled Buttons & Joystick
   To Control the BEAST.
Note: Do not connect BT module while using the
UHF. Only one wireless module at a time.

Enable RX

Disable RX
E-Gizmo
PS2 CTRLD

With UHF RX Only



  

PS2 CONTROLLED W/
PAN TILT

 1. After uploading your code for linesensors.
     Enable the RX pin to show display on the LCD.

2. Use the PS2 Controlled Buttons & Joystick
   To Control the BEAST.

Enable RX

Disable RX
E-Gizmo
PS2 CTRLD



  

Pin assignment in Pan Tilt

myServo1.attached(12);  // Base Servo
myServo1.attached(4);   // Tilt Servo

*Note: VCC & GND of Servo
Was interchanged.



  

Uploading codesBluetooth
On the Arduino IDE.
1. Bluetooth
    Go to File>Sketchbook>THE_BEAST..> BLUETOOTH

2. Board select
     Go to Tools>Boards>gizDuino + w/ Atmega644

3. Port select
     Go to Tools>Port>COM#
Select the correct port
Go to Device Manager
      if you're not sure.

Tips for uploading:
 Disable the Rx pin by switching
the Toggle Switch.

Enable RX

Disable RX

4. After you switched it. Click Upload.



  

BLUETOOTH CONTROLLED
 1. After uploading your code for linesensors.
     Enable the RX pin to show display on the LCD.

2. Use the HC-05 Bluetooth Module.
Note: Do not connect the UHF ,if you are
 Using BT module.

Enable RX

Disable RX
E-Gizmo
SUMO

3. Download the e-BOT MINIBOT APP on
Google Playstore.
- Follow the image instructions to
Connect it to your Smartphone.
SSID: HC-05
Password: 1234 or 0000



  

Uploading codesWith E-ARM
On the Arduino IDE.
1. With E-ARM Robotic Arm
    Go to File>Sketchbook>THE_BEAST..> EARM

2. Board select
     Go to Tools>Boards>gizDuino + w/ Atmega644

3. Port select
     Go to Tools>Port>COM#
Select the correct port
Go to Device Manager
      if you're not sure.

Tips for uploading:
 Disable the Rx pin by switching
the Toggle Switch.

Enable RX

Disable RX

4. After you switched it. Click Upload.



  

THE BEAST WITH EARM
 1. After uploading your code for linesensors.
     Enable the RX pin to show display on the LCD.

2. Use the PS2 Controller and UHF RX to
Control the BEAST.

Enable RX

Disable RX
E-Gizmo
SUMO

3. Use 16-Channel Servo Controller to the EARM.

To gizduino
RX to TX Digital Pin 4
TX to RX Digital Pin 5
GND to GND 

Input Supply
+VIN
GND

*Under development



  

Pin assignment in EARM
#include”eGizmo_16ChannelServo.h” //Library
SoftwareSerial softSerial(4, 5); //pins used
eGizmo_16channelServo servoDriver(&softSerial);

int DEGREES = 5; // increment,decrement of degrees value
// Initial Position
int G_POS = 90;
int T_POS = 90;
int E_POS = 50;
int S_POS = 50;
int B_POS = 170;

  servoDriver.moveServo(0, G_POS);  //Gripper Servo 0
  servoDriver.moveServo(1, T_POS);    //Twist Servo 1
  servoDriver.moveServo(2, E_POS);   //Elbow Servo 2
  servoDriver.moveServo(3, S_POS);   //Shoulder Servo 3
  servoDriver.moveServo(4, B_POS);   //Base Servo 4



  

EARM major parts

GRIPPER

ELBOW

SHOULDER

BASE

TWIST



  

E-ARM modified calibration
BASE           HOME = 170
GRIPPER HOLD = 10, OPEN = 140*
TWIST RIGHT= 160 ,HOME= 90 ,LEFT= 0
SHOULDER UP = 160 ,HOME=50, DOWN=0
ELBOW RETRACT =20,HOME= 50, EXTEND =160

* Do this at your own risk!!
You may use the Serial Monitor first to see the degree values,
Before setting it up. Do it for each servo until you find the correct degrees.



  

  Website: e-gizmo.net
Egizmo Tech blog: e-gizmo.net
 Facebook: eGizmoMechatronix
 Youtube Channel: e-Gizmo Mechatronix Central

For more info.
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